WordWPressPlugins gives you the freedom to easily change the PHP version from the Tools section of your WordWPressPlugins dashboard. You can choose any PHP version between 5.6 and 7.3 as well as control other settings, such as enabling/disabling HTTPS, etc.